Author Topic: Urgent help.  (Read 29961 times)

0 Members and 1 Guest are viewing this topic.

Offline Pure_Sincerity

  • post whore
  • *****
  • Posts: 1644
  • Karma: +6/-1
  • Gender: Male
  • noss is my father
Re: Urgent help.
« Reply #30 on: Feb 23, 2013, 02:21PM »
If it's only the signal wire to the engine control relay, than I'm bak where I started. The search for the 12 volt injector wire.
U12 TRX
KA25DE
HIGH COMP
MEGASQUIRT
COILOVERS
INDIVIDUAL THROTTLE BODIES

Offline Pure_Sincerity

  • post whore
  • *****
  • Posts: 1644
  • Karma: +6/-1
  • Gender: Male
  • noss is my father
Re: Urgent help.
« Reply #31 on: Feb 23, 2013, 02:34PM »
Unless the 12v injector wire is in that SMJ connector ? In which case, if the signal wire e1, gives off a 12 volt reading than I can tee the megasquirt 12v power wire into that, than the injectors and megasquirt would power at the same time ?

However, the 12v injector power wire does not run off a relay, which could be bad for the ms2 if its not on a relay the same as the factory ecu ?
U12 TRX
KA25DE
HIGH COMP
MEGASQUIRT
COILOVERS
INDIVIDUAL THROTTLE BODIES

Offline SSS

  • Administrator
  • post whore
  • *****
  • Posts: 8268
  • Karma: +5020/-3
  • Gender: Male
Re: Urgent help.
« Reply #32 on: Feb 23, 2013, 04:22PM »
That's the wire you said you were after before the relay......

Offline Pure_Sincerity

  • post whore
  • *****
  • Posts: 1644
  • Karma: +6/-1
  • Gender: Male
  • noss is my father
Re: Urgent help.
« Reply #33 on: Feb 23, 2013, 04:41PM »
I need to trace down the 12v power source for the injectors and splice it into the ECU power supply (pin 38) BEFORE the engine control relay so the megasquirt and injectors power up at the exact same time.

Where the fuck is this 12v injector power source wire located ?

I need to find the 12v injector power wire and splice it into pin 38 on the stock ecu, pin 38 is the factory ecu power source which runs on a relay, I need the injectors to run the same relay so they can power on at the same time all together.
U12 TRX
KA25DE
HIGH COMP
MEGASQUIRT
COILOVERS
INDIVIDUAL THROTTLE BODIES

Offline chr1S

  • r&d team
  • post whore
  • *****
  • Posts: 6995
  • Karma: +117/-116
  • Gender: Male
Re: Urgent help.
« Reply #34 on: Feb 24, 2013, 08:30AM »
You'd be surprised how far they range, I generally solder my splice joints because I can't be fucked buying scotch locks, but the amount of cars i've had to fix wiring and spastics - probably professional autoelectricians rape the loom with fatigued solder joints is not funny.

I don't like solder on automotive wiring unless the stress is taken away from the soldered joint, it is asking for some severe trouble in 5 years down the track - heatshrinked with PROPER milspec heatshrink is ok because this removes some of the load, but vibration about the solder joint is just fucked.

In particular this one time an engine was fucking bucking in and out of vtec randomly - made me strip a motor over it.  >:(
Don't let the opinions of the average man sway you. Dream, and he thinks you're crazy. Succeed, and he thinks you're lucky. Acquire wealth, and he thinks you're greedy. Pay no attention. He simply doesn't understand.

Quote
to be fair, it wouldn't be ANTRX if we stayed on topic.

and if someone wasn't cranky at Chr1s for something he said...

Offline SSS

  • Administrator
  • post whore
  • *****
  • Posts: 8268
  • Karma: +5020/-3
  • Gender: Male
Re: Urgent help.
« Reply #35 on: Feb 24, 2013, 11:43AM »
I need to find the 12v injector power wire and splice it into pin 38 on the stock ecu, pin 38 is the factory ecu power source which runs on a relay, I need the injectors to run the same relay so they can power on at the same time all together.

that should still be the right wire, as on the std ecu side of the SMJ it goes back to the fuse box, fused with a 10a fuse, then goes to pin 38 on the std ecu.

Offline SleepaTi

  • antrx.com junkie
  • *****
  • Posts: 963
  • Karma: +17/-14
  • Gender: Male
  • KA24DET Guru
Re: Urgent help.
« Reply #36 on: Feb 24, 2013, 12:07PM »


injectors get their ~V from the fusible link & the ecu earths them out to activate them.
NO! it's NOT a fucking SR20!!

Offline Pure_Sincerity

  • post whore
  • *****
  • Posts: 1644
  • Karma: +6/-1
  • Gender: Male
  • noss is my father
Re: Urgent help.
« Reply #37 on: Feb 24, 2013, 01:07PM »
Sleepa is right, me and the old man just found it before I logged on.
U12 TRX
KA25DE
HIGH COMP
MEGASQUIRT
COILOVERS
INDIVIDUAL THROTTLE BODIES

Offline Pure_Sincerity

  • post whore
  • *****
  • Posts: 1644
  • Karma: +6/-1
  • Gender: Male
  • noss is my father
Re: Urgent help.
« Reply #38 on: Feb 24, 2013, 04:04PM »
Everything is wired in where it should be, but the MS2 is not receiving any power. Used a multimeter and there is 12v coming from under the relay. Ideas ?

There is also 12v going through the cable into the plug on the MS2 but my laptop is not picking up a signal from the MS2
« Last Edit: Feb 24, 2013, 04:28PM by Pure_Sincerity »
U12 TRX
KA25DE
HIGH COMP
MEGASQUIRT
COILOVERS
INDIVIDUAL THROTTLE BODIES

Offline pedro666

  • post whore
  • *****
  • Posts: 2326
  • Karma: +26/-8
  • Gender: Male
  • VET NEO VVL is how I roll...
Re: Urgent help.
« Reply #39 on: Feb 25, 2013, 08:36AM »
its not a driver issue is it?
the words "race car" spelled backward still spell "race car"? 




skype_shannan801

Offline SSS

  • Administrator
  • post whore
  • *****
  • Posts: 8268
  • Karma: +5020/-3
  • Gender: Male
Re: Urgent help.
« Reply #40 on: Feb 25, 2013, 09:28AM »
Sleepa is right, me and the old man just found it before I logged on.

But you said you needed to connect to the 12v supply wire between the ECU and the relay? That's how I understood your question.

Everything is wired in where it should be, but the MS2 is not receiving any power. Used a multimeter and there is 12v coming from under the relay. Ideas ?

There is also 12v going through the cable into the plug on the MS2 but my laptop is not picking up a signal from the MS2

Is the MS2 grounded correctly? Or did you tee it's ground into the standard ecu's ground?

Offline Pure_Sincerity

  • post whore
  • *****
  • Posts: 1644
  • Karma: +6/-1
  • Gender: Male
  • noss is my father
Re: Urgent help.
« Reply #41 on: Feb 25, 2013, 09:31AM »
The 5 Ms2 ground wires are direct connected to the negative side of the battery.
U12 TRX
KA25DE
HIGH COMP
MEGASQUIRT
COILOVERS
INDIVIDUAL THROTTLE BODIES

Offline Pure_Sincerity

  • post whore
  • *****
  • Posts: 1644
  • Karma: +6/-1
  • Gender: Male
  • noss is my father
Re: Urgent help.
« Reply #42 on: Feb 25, 2013, 04:32PM »
It's a bit of a mindfuck.

Alright.

Fuel pump relay is direct connected through the MS2 and when you turn the ignition on you can hear the fuel pump prime, and if the ecu wasn't working it obviously wouldn't. But megatune will not pick it up...
U12 TRX
KA25DE
HIGH COMP
MEGASQUIRT
COILOVERS
INDIVIDUAL THROTTLE BODIES

Offline SleepaTi

  • antrx.com junkie
  • *****
  • Posts: 963
  • Karma: +17/-14
  • Gender: Male
  • KA24DET Guru
Re: Urgent help.
« Reply #43 on: Feb 25, 2013, 07:13PM »
should have just got a nistune'd ecu, direct plug & play ;)

i'm running a nistune'd S13 240sx ecu in my bluey, absolutely everything is adjustible via consult
NO! it's NOT a fucking SR20!!

Offline Kranzy

  • Administrator
  • post whore
  • *****
  • Posts: 3500
  • Karma: +66/-4
  • Gender: Male
  • U12 - SR20DET
Re: Urgent help.
« Reply #44 on: Feb 25, 2013, 07:50PM »
Can nistune be used to go from maf to map?

I've got nistune and its awesome! But Aaron needed to use a map sensor.
Quote from: noss
learnt something new just then, dont eat baked bean sandwhiches while changing the paper in the copier


"Noss is GOD"

Offline chr1S

  • r&d team
  • post whore
  • *****
  • Posts: 6995
  • Karma: +117/-116
  • Gender: Male
Re: Urgent help.
« Reply #45 on: Feb 25, 2013, 09:55PM »
There is a MAP option running nistune.
Don't let the opinions of the average man sway you. Dream, and he thinks you're crazy. Succeed, and he thinks you're lucky. Acquire wealth, and he thinks you're greedy. Pay no attention. He simply doesn't understand.

Quote
to be fair, it wouldn't be ANTRX if we stayed on topic.

and if someone wasn't cranky at Chr1s for something he said...

Offline crazy2287

  • antrx.com full member
  • ***
  • Posts: 172
  • Karma: +5/-0
  • Gender: Male
Re: Urgent help.
« Reply #46 on: Feb 25, 2013, 10:45PM »
Lol, what a fk fight!

Sounds like my issues trying to find the headlight relays on these damn things. After a few hours of searching i just gave up and put a whole new circuit in. The wiring on these is all spacko.

The Fuel pump should not be directly powered by the ECU, the ECU should activate a relay to power fuel pump. this same relay is typically used to power the 3-4 wire EGO sensors as well.

The MS needs 12v IGN power typically should run parallel off the same main power relay as the injectors and your coil depending on setup. ALL OTHER MS ACTIVATED RELAYS should receive their +12 from this same source as the MS, or you can risk getting stray volts back through your MS when its 'powered off' when your using the standard design input/output's.

Do you have a megasquirt stimulator? (not sexual)

Are the status LED's on the mega squirt activating?

Piggybacking has made the install sound alot more complicated then it would otherwise be? Any reason you are not using the MS as a stand-alone control?

+1 on the "plugging it in and crossing your fingers" bit. If you do this is it only a matter of time till your fry the MS. then your going to have to learn real quick how to do circuit track and component repairs. You need to be familiar with the operation of a multimeter and put it to good use. It is a simple tool to learn and can be had from bunnings for $10

+1 on those bloody shitty splice connectors been the devil. Curse the man who invented them. If your soldering and looming properly you should not be getting stress failures. This is not fault of the technique but the person(s) trying to carry it out. too much heat, too little heat, wicking and contaminated joins. all avoidable problems. you cannot, however, avoid how craptastic those splices are.



« Last Edit: Feb 25, 2013, 11:18PM by crazy2287 »
I drive like i screw..... illegally =D... wait O.o WHAT?? O.O

Offline Pure_Sincerity

  • post whore
  • *****
  • Posts: 1644
  • Karma: +6/-1
  • Gender: Male
  • noss is my father
Re: Urgent help.
« Reply #47 on: Feb 25, 2013, 10:57PM »
The Fuel pump should not be directly powered by the ECU, the ECU should activate a relay to power fuel pump. this same relay is typically used to power the 3-4 wire EGO sensors as well.

The MS needs 12v IGN power typically should run parallel off the same main power relay as the injectors and your coil depending on setup. ALL OTHER MS ACTIVATED RELAYS should receive their +12 from this same source as the MS, or you can risk getting stray volts back through your MS when its 'powered off' when your using the standard design input/output's.

Do you have a megasquirt simulator? (not sexual)

Are the status LED's on the mega squirt activating?

Piggybacking has made the install sound alot more complicated then it would otherwise be? Any reason you are not using the MS as a stand-alone control?

+1 on the "plugging it in and crossing your fingers" bit. If you do this is it only a matter of time till your fry the MS.

The fuel pump is still going through a relay. I had wired the fuel pump to run off the MS relay. As for the injectors, I have them running on the same power relay as the ecu as stated in the MS manuals. Also no, I do not have a MS simulator and no LEDs are not activatin on the ecu. I checked everything before I tested the MS2, put everything where it should be and run the injectors off the same power source as the ecu. From my understandings it should work right now.
U12 TRX
KA25DE
HIGH COMP
MEGASQUIRT
COILOVERS
INDIVIDUAL THROTTLE BODIES

Offline crazy2287

  • antrx.com full member
  • ***
  • Posts: 172
  • Karma: +5/-0
  • Gender: Male
Re: Urgent help.
« Reply #48 on: Feb 25, 2013, 11:23PM »
The fuel pump is activated BY the MS. not powered by the MS's power relay. The MS should have its fuel pump output to a relay that in turn powers the fuel pump.
If i read your post correctly it sounded like the fuel pump was connected to the same relay as the megasquirt and injectors? Then this is the reason it is running, this does not indicate that the MS is booting.

You may have to go back to square 1, apply power only to the MS and check it is actually booting.


Where about are you located? anywhere near Nowra?
« Last Edit: Feb 25, 2013, 11:25PM by crazy2287 »
I drive like i screw..... illegally =D... wait O.o WHAT?? O.O

Offline SSS

  • Administrator
  • post whore
  • *****
  • Posts: 8268
  • Karma: +5020/-3
  • Gender: Male
Re: Urgent help.
« Reply #49 on: Feb 26, 2013, 07:17AM »
There is a MAP option running nistune.

Matt does not offer a MAP conversion for MAF based ecu's mate. You are thinking of Gabe's conversion.
Funnily enough, I still haven't tried to get working yet on the black car.

Aaron, buy a one of the "JimStim" stimulators as crazy mentioned, it readily allows you to diagnose issues such as this.

Offline chr1S

  • r&d team
  • post whore
  • *****
  • Posts: 6995
  • Karma: +117/-116
  • Gender: Male
Re: Urgent help.
« Reply #50 on: Feb 26, 2013, 09:01AM »
What?

A friend of mine was getting MAP based nistune for his VH45, what happpened to it ?
Don't let the opinions of the average man sway you. Dream, and he thinks you're crazy. Succeed, and he thinks you're lucky. Acquire wealth, and he thinks you're greedy. Pay no attention. He simply doesn't understand.

Quote
to be fair, it wouldn't be ANTRX if we stayed on topic.

and if someone wasn't cranky at Chr1s for something he said...

Offline SSS

  • Administrator
  • post whore
  • *****
  • Posts: 8268
  • Karma: +5020/-3
  • Gender: Male
Re: Urgent help.
« Reply #51 on: Feb 26, 2013, 09:52AM »
I couldn't find any new info on the nistune site.

Offline Pure_Sincerity

  • post whore
  • *****
  • Posts: 1644
  • Karma: +6/-1
  • Gender: Male
  • noss is my father
Re: Urgent help.
« Reply #52 on: Feb 26, 2013, 10:15AM »
Spoke to Matt Cramer again guys, he said that the led lights do not come on the ecu when when power is going trough it. Told me to download portcheck.exe from his site and run a thorough scan of all ports to find the ECU. Once found it should come up with the MS firmware etc. will be running the scan later today. If all goes well, there should be a startup video posted :p but not likely knowin my luck :/
U12 TRX
KA25DE
HIGH COMP
MEGASQUIRT
COILOVERS
INDIVIDUAL THROTTLE BODIES

Offline noss

  • Administrator
  • post whore
  • *****
  • Posts: 13880
  • Karma: +275/-50
  • Gender: Male
  • great scott!
    • antrx
Re: Urgent help.
« Reply #53 on: Feb 26, 2013, 12:40PM »
What?

A friend of mine was getting MAP based nistune for his VH45, what happpened to it ?

wasn't that work between nistune and gabe? and then nistune didn't want to credit/pay gabe for his work? that might have just been rumours though

http://polyfedelicio.us/imgs/ - free image hosting for whatever you like

Offline Pure_Sincerity

  • post whore
  • *****
  • Posts: 1644
  • Karma: +6/-1
  • Gender: Male
  • noss is my father
Re: Urgent help.
« Reply #54 on: Feb 26, 2013, 02:52PM »
Fuck sake, port check failed, computer is not picking anything up. Sent a screenshot of results back to Matt Cramer. Just need to wait another day or 2 for another response.
U12 TRX
KA25DE
HIGH COMP
MEGASQUIRT
COILOVERS
INDIVIDUAL THROTTLE BODIES

Offline Pure_Sincerity

  • post whore
  • *****
  • Posts: 1644
  • Karma: +6/-1
  • Gender: Male
  • noss is my father
Re: Urgent help.
« Reply #55 on: Feb 26, 2013, 04:26PM »
Considering purchasing a stimulator, however I will wait untill Matt replies to me again. Unless you have one I could possibly borrow crazy ? I'm located in qld though, I will pay for postage here and back. Let me know.
U12 TRX
KA25DE
HIGH COMP
MEGASQUIRT
COILOVERS
INDIVIDUAL THROTTLE BODIES

Offline crazy2287

  • antrx.com full member
  • ***
  • Posts: 172
  • Karma: +5/-0
  • Gender: Male
Re: Urgent help.
« Reply #56 on: Feb 26, 2013, 05:00PM »
I do have one and if you were closer i would let you burrow but over that distance it's a bit pointless.

I recommend you purchase a Jim Stim and assemble it. For the cost you will then always have it on call when you need it. It's not only for trouble shooting but you can run all sorts of test and use it to simulate buildups to mods and things.

Read the instructions slowly and twice over ad the stim itself can be a little confusing to set up. and it not protected SO IF YOU HOOK SOMETHING UP WRONG YOU CAN DESTROY THE STIM, THE MS OR BOTH.

Just relax, I know it must be killing you to get it running as soon as you can but take it step by step and check everything over and then over again. Understand everything you do and hook up, rather then just going "the red ones connected to the blue one"
This way you will walk away from the project with alot more knowledge and experience which will make everything a FK load easier down the track. and ultimately it will be smoother, less expensive and more rewarding.

there could be a plethora of issues stopping you from connecting to the computer. It might help to simulate a shadow return on your com port. You have to get the com cable and short 2 pins then open up a telnet window and ping a signal through the com cable and watch for the return. Then you will know the computer side is working AND what com port you are using.

I will try and find the reference for you.
I drive like i screw..... illegally =D... wait O.o WHAT?? O.O

Offline crazy2287

  • antrx.com full member
  • ***
  • Posts: 172
  • Karma: +5/-0
  • Gender: Male
Re: Urgent help.
« Reply #57 on: Feb 26, 2013, 05:05PM »
http://www.megamanual.com/v22manual/mass.htm
To see it in the original click that link ^ and search "hyperterminal"
This is and extract of what i am talking about.


B. Connect the serial cable to your computer, but not to the MegaSquirt ECU yet. Use an alligator clip or something similar to jumper pins 2 and 3 on the loose end of the cable. This provides a loopback circuit to verify the operation of your computer and the cable without involving the MegaSquirt® hardware yet.

C. Download the HyperTerminal configuration file by clicking on the link (then go to step D.), save it to your hard drive, then click on its icon to start HyperTerminal. Note that the configuration is set for com port #1, you may have to change this. OR you can set up Hyperterminal yourself:



i. On the PC, find and run HyperTerminal (Hyperterminal is usually under Start/Programs/Accessories/Communications, but if it is not there then search for a file called “hyperterm.exe”).
If you do not have HyperTerminal installed, you can get it from Hilgraeve, who wrote the original for Microsoft Windows. HyperTerminal Private Edition (HTPE) is what you want, and it's free for personal use.

ii. When Hyperterm appears, click on the red telephone icon, and enter a save file name (anything you want, say, "megasquirt").

iii. When the "Connect To" dialog comes up, select under the "Connect Using" option the COM port to which the DB-9 cable is connected, i.e., COM1 or COM2. Do not worry about any of the other settings. Click OK.

iv. Next, a dialog window opens with baud rate, stop bits, etc. Set the values according to the table below. Note: the last one, Flow Control, is very important – be sure to set it to None. Click OK.

Baud Rate

9600 - MegaSquirt
115200 - MegaSquirt-II

Data Bits

8

Stop Bits

1

Flow Control

None

D. HyperTerminal now is up and "connected."

E. Type any character - it should be echoed back to the screen, i.e. you will see it once if you do not have local echo enabled, twice if you do. Note that the above configuration file has the local echo set to "off". If the character you typed appears on the screen then the link is working. If not, then check the cable connections and try different COM ports. You must see characters echoed correctly before you move on.
« Last Edit: Feb 26, 2013, 05:06PM by crazy2287 »
I drive like i screw..... illegally =D... wait O.o WHAT?? O.O

Offline Pure_Sincerity

  • post whore
  • *****
  • Posts: 1644
  • Karma: +6/-1
  • Gender: Male
  • noss is my father
Re: Urgent help.
« Reply #58 on: Feb 27, 2013, 07:04AM »
Results for the port check came up "0 valid ports found" Matt Cramer stated that when those results are found, it is generally a fault on the PC side.

So I may try another laptop and install megatune etc again.
U12 TRX
KA25DE
HIGH COMP
MEGASQUIRT
COILOVERS
INDIVIDUAL THROTTLE BODIES

Offline SSS

  • Administrator
  • post whore
  • *****
  • Posts: 8268
  • Karma: +5020/-3
  • Gender: Male
Re: Urgent help.
« Reply #59 on: Feb 27, 2013, 09:19AM »
Have you gone into system settings and checked to make sure that at least one COM port is switched on and configured as crazy detailed?